Modelle lassen sich nicht einfügen im level editor

Tombery

Crash
Ich hab das jetzt auch über Texturen umgestellt.

So hatte ich das schon mal ausprobiert aber die Texturen über den Model Ordner.
m8pkp4.png


Ach was hab ich da vorher geschrieben.. der Ipot ist ja nicht aus Zbrush, ich werde langsam Kirre. :ugly:
 

MacX

Light Guard
Kannst du die notwendigen Dateien mal irgendwo hochladen? Würde das ganz gerne mal bei mir testen.
 

MacX

Light Guard
Ich habe mir sagen lassen, das Doom3 Texturen mit Auflösung > 1024*1024 nicht so gerne hat.
Hast du einen der hier http://www.modwiki.net/wiki/Modelling gelisteten Exporter benutzt?

Bisher habe ich versucht stone_wand.ase anhand von vorhandenen .ase-Dateien anzupassen. Die .tgas habe ich runterskaliert auf 512*512.
Bisher ohne Erfolg. Kann jetzt nicht sagen, ob es am Exporter liegt, an den Texturen oder sonstigen Einstellungen.

Ich versuche es noch ein wenig und gebe bescheid, wenn es was neues gibt.
 

Tombery

Crash
Ich habe den exporter aus Blender verwendet (v-0.6.2) , ich schau mal nach einem anderen Exporter um.
Texturen verwende ich meist 4096x4096, die funktionieren auch im Radiant.
 
Last edited:

MacX

Light Guard
Habe folgenden Thread gefunden: http://doom3world.org/phpbb2/viewtopic.php?f=3&t=22988
Nach ein bisschen Spielerei meine ich jetzt, das nicht die ASE sondern die TGAs das Problem sind.

Edit: Der erste Unterstrich im Namen "stone_wand_xxx.tga" muss scheinbar weg. Also mit "stonewand_xxx.tga" passiert zumindest was im Editor.

Habe folgenden Thread gefunden: http://doom3world.org/phpbb2/viewtopic.php?f=3&t=22988
Nach ein bisschen Spielerei meine ich jetzt, das nicht die ASE sondern die TGAs das Problem sind.

Edit: Der erste Unterstrich im Namen "stone_wand_xxx.tga" muss scheinbar weg. Also mit "stonewand_xxx.tga" passiert zumindest was im Editor.

Folgende Einstellungen habe ich nun:

ASE
Code:
*MATERIAL_LIST {
    *MATERIAL_COUNT 1
    *MATERIAL 0 {
        *MATERIAL_NAME "01 - Default"
        *MATERIAL_CLASS "Standard"
        *MATERIAL_AMBIENT 0.5882    0.5882    0.5882
        *MATERIAL_DIFFUSE 0.5882    0.1882    0.1882
        *MATERIAL_SPECULAR 0.9000    0.9000    0.9000
        *MATERIAL_WIRESIZE 1.0000
        *MATERIAL_SHADING Blinn
        *MATERIAL_XP_FALLOFF 0.0000
        *MATERIAL_SELFILLUM 0.0000
        *MATERIAL_FALLOFF In
        *MATERIAL_XP_TYPE Filter
        *MAP_DIFFUSE {
            *MAP_NAME "Map #1"
            *MAP_CLASS "Bitmap"
            *MAP_SUBNO 1
            *MAP_AMOUNT 1.0000
            *BITMAP "\\base\models\test\stonewand"
            *MAP_TYPE Screen
            *UVW_U_OFFSET 0.0000
            *UVW_V_OFFSET 0.0000
            *UVW_U_TILING 1.0000
            *UVW_V_TILING 1.0000
            *UVW_ANGLE 0.0000
            *UVW_BLUR 1.0000
            *UVW_BLUR_OFFSET 0.0000
            *UVW_NOUSE_AMT 1.0000
            *UVW_NOISE_SIZE 1.0000
            *UVW_NOISE_LEVEL 1
            *UVW_NOISE_PHASE 0.0000
            *BITMAP_FILTER Pyramidal
        }
    }
}

Material
Code:
models/test/stonewand
{
    bumpmap     textures/test/stonewand_local.tga
    diffusemap     textures/test/stonewand_d.tga
    specularmap     textures/test/stonewand_s.tga
}

Die Texturen haben alle die Größe 1024*1024 und besitzen keinen Alpha Channel.


Sieht nicht so berauschend aus. So sieht es übrigens auch aus, wenn man die bump und specular weglässt.
 
Last edited:

Tombery

Crash
Ich habe jetzt mal von Maya zu Doom direkt eine ASE mit allen Texturen/Material exportiert, die muss ich nur noch finden aber irgend wie ist es zu einfach um wahr zu sein.
 

Tombery

Crash
Mit Blender, aber maya ist grad unzuverlässig.

Edit:
Habs auch grad mit dem Ipod genauso ausprobiert aber mit Alpha channel immer noch unverändert.
Ich merke grad, bevor die ASE exportiert wird müssen die Texturen mit der Material auf das Model.
 
Last edited:

Tombery

Crash
Oh ja danke, werde ich nachher mal durchgehen.
Ich werd in zwischenzeit mal schauen wie man die Texturen in Blender aufs Model bekommt.

Edit: Ich habs entlich geschafft dank des Tutorials, es ist zwar noch nicht perfekt aber schon mal ein Anfang.
Der Fehler war bei der Ase datei, "BITMAP" und man muss mit den Texturen exportieren, Textur grösse spielt keine Rolle. Schatten fehlen nur noch und der Shader könnte besser sein.
4g222p.png

Hier der Download:
http://www.file-upload.net/download-2574938/pak666.pk4.html
 
Last edited:

MacX

Light Guard
Hey, cool. Der Übersicht halber würde ich dir aber empfehlen, den zusammengehörenden TGA-Dateien den gleichen Namen zu geben (bis auf die Endung).

Also statt:

colorstone_d.tga
colorstone_ed.tga
Specmapstone_s.tga.tga ( hier ist übrigens ein ".tga" zuviel )
normalmapstone_local.tga

Dann:

mystone_d.tga
mystone_ed.tga
mystone_s.tga
mystone_local.tga

xxx_d.tga und xxx_ed.tga sind bei dir auch dieselben. Da reicht für Diffusemap und Editorimage auch die xxx_d.tga. Bedenke das eine TGA davon schon 64MB (komprimiert ca. 9MB) groß ist. Also, falls du das in eine Map packen und dann veröffentlichen willst solltest du überprüfen, welche Dateien du wirklich brauchst.
 

ReFlex

Shambler
"colorstone_d.tga" Das ".tga" kann man sich auch sparen im shader, es reiht wenn nur der Name drin steht.

so: "
colorstone_d"
 

Tombery

Crash
Ich habe die TGAs Übersicht halber angepasst, das sieht auch besser aus, Danke.
Gestern hatte ich das erstmal so weit fertig gemacht, das ist schon mal die Hälfte der Strecke. Denn mir scheint das die Bumpmap nicht richtig angenommen wird und so wie das jetzt aussieht reichen schon 1024x1024.TGA ausser wenn sich die Auflösungen ansehnlich loht und Schatte da sind.

xxx_ed.tga kann man auf 250x250 Pixel verkleinern, jeden falls beim Ipod war das so und hatte kein Einfluss- muss ich aber nochmal prüfen.

In Game habe ich irgend wie kein Licht, ich weiss jetzt nicht ob das am Radiant liegt oder an den Models.

Und die ".tga" im Shadermuss bei mir stehen sonst ist das Model im Radiant nicht sichtbar, eigentlich sollte das auch ohne reichen.
 
Top